Maytech
+ Reply to Thread
Results 1 to 5 of 5

Thread: OS Giken Quad Plate - noises (not the rattle)

  1. #1
    Join Date
    Nov 2003
    Location
    Perth
    Posts
    1,028

    OS Giken Quad Plate - noises (not the rattle)

    Looking to hear from people with solid centre multiplate clutches (the cam with rings type, not the normal plate style).

    Installed mine a while ago with the release bearing specified by os giken, didnt really drive it after the install except for a few minutes up the road.
    Went for a quick drive on sat and the sucker makes an unusual screeching sort of noise as it engages when I get off the clutch quickly (its on/off so it doesnt take much). I've had a few twin plates before (the normal sprung, plate variety) so im not new to the rattles and other noises with these clutches, but this isnt a noise I've heard before.

    So, normal or not?

    Cheers

  2. #2
    Join Date
    Aug 2004
    Location
    Ballas
    Posts
    169
    Nissan's make a dirty vibrating grinding noise when the spigot bush is fucked.

    Is it new?

  3. #3
    Join Date
    Nov 2003
    Location
    Perth
    Posts
    1,028
    yep that sounds about right. I didnt even think of changing it at the time

    thanks dude

  4. #4
    Join Date
    Feb 2020
    Posts
    1
    Excuse me for asking, but what are you referring to as the "spigot bush"?
    I just got an R33 with a quad OS that has a grind to it as I disengage into first gear from a dead stop only, the rest of the drive is seemingly normal.

  5. #5
    Join Date
    May 2005
    Posts
    4,303
    Spigot bush or bearing in some cases are a small but that go into the end of the crankshaft. The gearbox input shaft runs on it and keeps things in line.

    The clutch assembly obviously then runs on the input shaft.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts